HIgh load
Incident Report for Codio
Postmortem

Hello

I am really sorry for the inconvenience caused by the slow down and partial unavailability. We conducted an investigation, and it looks like AWS throttled our application load balances due to “high traffic.” This throttling led to several micro-services internal requests timeouts and CPU usage spikes. It is not clear exactly the reason for this behavior, and we are working with AWS on a solution to avoid that in the future. As a temporary solution, we upgraded instance types, and the team closely monitors the situation.

Thank you,
Max, Codio CTO

Posted Feb 07, 2022 - 05:51 GMT

Resolved
This incident has been resolved.
Posted Feb 07, 2022 - 04:32 GMT
Update
We are continuing to investigate this issue.
Posted Feb 07, 2022 - 04:32 GMT
Investigating
We are currently investigating this issue.
Posted Feb 07, 2022 - 04:16 GMT
Update
We are continuing to monitor for any further issues.
Posted Feb 07, 2022 - 03:49 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 07, 2022 - 03:49 GMT
Investigating
We are currently investigating this issue.
Posted Feb 07, 2022 - 03:38 GMT
This incident affected: Application.